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1 License agreement

  Dekart.
  http://www.dekart.com

                    END-USER SOFTWARE LICENSE AGREEMENT

IMPORTANT: THIS END-USER SOFTWARE LICENSE AGREEMENT ("AGREEMENT") IS A LEGAL
AGREEMENT  BETWEEN YOU  (EITHER  AN  INDIVIDUAL  OR  A  SINGLE  ENTITY)  AND  DEKART.
("DEKART")  FOR  THE  SOFTWARE  IDENTIFIED  ABOVE.  BY  INSTALLING,  COPYING,  OR
OTHERWISE  USING  ALL  OR  ANY  PORTION  OF  THE  SOFTWARE  YOU  ACCEPT  ALL  THE
TERMS AND CONDITIONS OF THIS  AGREEMENT.  IF  ANY OF THE  TERMS  AND  CONDITIONS
ARE  NOT  ACCEPTABLE  TO  YOU,  DO  NOT  USE  THE  SOFTWARE;  INSTEAD,  RETURN  THE
PACKAGE  TO  THE  COMPANY  FROM  WHICH  YOU  RECEIVED  IT  AND  YOU  WILL  RECEIVE  A
FULL REFUND IF YOU: (A) DO NOT USE THE SOFTWARE AND (B) RETURN IT WITH PROOF OF
PAYMENT WITHIN THIRTY (30) DAYS OF THE PURCHASE DATE.

1.  DEFINITIONS.  "Software"  means (a)  all  of  the  contents  of  the  files,  disk(s),  CD-ROM(s)  or  other
media  with  which  this  Agreement  is  provided,  including  but  not  limited  to  (i)  Dekart  or  third  party
computer information or software; (ii) related explanatory written materials or files ("Documentation");
and (iii) fonts; and (b) upgrades, modified versions, updates, additions, and copies of the Software, if
any,  licensed  to  you  by  Dekart  (collectively,  "Updates").  "Use"  or  "Using"  means  to  access,  install,
download, copy or otherwise benefit from using the functionality of the Software in accordance with the
Documentation. "Dekart" means Dekart  SRL, having its legal address at Alba Iulia 75, Chisinau, MD
2071, Moldova, and / or its affiliates/branches.

2. GRANT OF LICENSE. As long as you comply with  the terms of  this  Agreement,  Dekart  grants  to
You  a  non-exclusive,  non-transferable  right  for  Your  internal  use  to  Use  the  Software  in  a  quantity
necessary for its intended purposes described in the Documentation. The Software may include or be
bundled with other software programs licenses under different terms and/or licensed by a vendor other
than  Dekart.  Use  of  any  software  programs  accompanied  by  a  separate  license  agreement  is
governed by that separate license agreement. Any third party software that may be provided with the
Software is included for use at Your option. Dekart is not responsible for any third party's software and
shall have no liability for Your use of third party software.

2.1.  With  the  STANDARD  SINGLE-USER  License  Dekart  grants  you  with  the  right  to  use  the
accompanying  Dekart  Software  and  any  of  its  updates  that  you  may  receive  on  a  single  terminal
connected to a single computer  (i.e.,  with  a single CPU).  You may,  however,  install  the Software on
more  than  one  computer  provided  you  do  not  operate  the  Software  on  more  than  one  computer  or
computer  terminal  at  a  time.  In  case  the  user  needs  to  deploy  the  purchased  software  on  several
computers simultaneously another license has to be purchased, namely Multi-User License or the user
may alternatively select to have a separate license key per each terminal.

2.2. MULTI-USER, NETWORK LICENSE. You may use the Software on a network only if a separate
copy  of  the  Software  has  been  licensed  from  Dekart  for  each  terminal  and/or  CPU  capable  of
executing  the  Software.  Otherwise,  if  you  desire  to  use  the  Software  on  a  network  or  multi-user
system, or to install the Software on multiple single-user CPUs, you must first obtain written multi-user
authorization  (a  "Multi-user  License")  from  Dekart.  Under  a  Multi-user  License,  you  may  install  the
Software on networks and/or multiple single-user CPUs, provided the total concurrent network usage
or  total  number  of  network  installations  (whichever  is  greater),  plus  the  total  number  of  single-user
installations,  does  not  exceed  the  total  number  of  machines/users  authorized  by  Dekart.  The  Multi-
User  License  Key  consists  of  a  standard  combination  of  25  symbols  plus  5  more  symbols  which
indicate the overall number of users authorized by Dekart with this particular license.
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3.  EVALUATION.  If  the  Software  is  an  evaluation  version  or  is  provided  to  You  for  evaluation
purposes,  then  Your  license  to  use  the  Software  is  limited  solely  to  internal  evaluation  purposes  in
accordance  with  the  terms  of  the  evaluation  offering  under  which  You  received  the  Software  and
expires 30 days from installation (or such other period as indicated by the Software) and the Software
may  cease  to  function.  Upon  expiration  of  the  evaluation  period,  You  must  discontinue  use  of  the
Software and delete the Software entirely from Your system. The Software may contain an automatic
disabling mechanism that prevents its use after a certain period of time, so You should back up Your
system and take other measures to prevent any loss of files or data.

4. REFUNDS. Products that can be downloaded prior to the purchase are NOT refundable. Optionally,
our technical support team can decide that an exception to the rule can be made, after an examination
of  the  problem.  You  have  the  chance  to  'try  before  you  buy'.  We  would  like  to  emphasize  that  the
evaluation period is an important phase and we encourage you to explore the programs and try all their
options before the purchase.  If  you have not  tested  the fully-functional,  free  evaluation  versions  that
can be retrieved from our download site(s), PLEASE do so before you place your order to make sure
that the product you are ordering is the product you need.

5.  INTELLECTUAL  PROPERTY RIGHTS.  The  Software  and  any  copies  that  You  are  authorized  by
Dekart to make are the intellectual property of and are owned by Dekart. No title to or ownership of the
Software  is  transferred  to  You.  Dekart  owns  and  retains  all  title  and  ownership  of  all  intellectual
property rights in the Software, including any adaptations or copies. You acquire only a license to use
the Software. The structure, organization and code of the Software are the valuable trade secrets and
confidential information of Dekart. The Software is copyright protected.

6.  NON-DEKART  PRODUCTS.  The  Software  may  include  or  be  bundled  with  hardware  or  other
software programs licensed or sold by a vendor other then Dekart. Any such products are provided on
and "AS IS" basis and are not warranted by Dekart.  Any warranty service for non-Dekart  products is
provided by the product vendor in accordance with the applicable vendor warranty.

7. LIMITED WARRANTY. Dekart warrants to You that for ninety (90) days from date of purchase (the
"Warranty  Period):  (a)  the  media  on  which  the  Software  is  stored  will  be  free  of  defects;  (b)  the
Software will substantially conform to the Documentation accompanying the Software. If the defective
item(s) are returned to Dekart or if  You send an error report(s) to Dekart within the Warranty Period,
Dekart will  at its sole discretion either resolve the problem(s),  or  replace the Software,  or  refund the
license fees You paid for the Software. Any misuse or unauthorized modification of the Software voids
this warranty. The warranty referenced above is  Your sole and exclusive remedy and is  in  lieu of  all
other  warranties,  express  or  implied.  The  warranty  referenced  above  does  not  apply  to  Software
provided free  of  charge.  Such Software  is  provided "AS IS"  without  any  warranties  of  any  kind.  The
Software  is  not  designed,  manufactured  or  intended  for  use  of  distribution  with  on-line  control
equipment  in  hazardous  environments  requiring  fail-safe  performance.  Such  as  in  the  operation  of
nuclear facilities, aircraft navigation, communication, or control systems, direct life support machines,
weapons systems, or other uses in which failure of the software could lead directly to death, personal
injury, or serve physical or environment damage.

8.  LIMITATION  OF  LIABILITY.  IN  NO  EVENT  WILL  DEKART  BE  LIABLE  TO  YOU  FOR  ANY
DAMAGES,  CLAIMS  OR  COSTS  WHATSOEVER  OR  ANY  CONSEQUENTIAL,  INDIRECT,
INCIDENTAL  DAMAGES,  OR  ANY  LOST  PROFITS  OR  LOST  SAVINGS,  EVEN  IF  AN  DEKART
REPRESENTATIVE  HAS  BEEN  ADVISED  OF  THE  POSSIBILITY  OF  SUCH  LOSS,  DAMAGES,
CLAIMS  OR  COSTS  OR  FOR  ANY  CLAIM  BY  ANY  THIRD  PARTY.  THE  LIMITATIONS  AND
EXCLUSIONS  REFERENCED  ABOVE  APPLY  TO  THE  EXTENT  PERMITTED  BY  APPLICABLE
LAW IN YOUR JURISDICTION. DEKART'S AGGREGATE LIABILITY UNDER OR IN CONNECTION
WITH THIS AGREEMENT SHALL BE LIMITED TO THE AMOUNT PAID FOR THE SOFTWARE, IF
ANY. The above exclusions and limitations will not apply to claims relating to death or personal injury.
In those jurisdictions that do not allow the exclusion or limitations damages, Dekart's liability shall  be
limited or excluded to the maximum extent allowed within those jurisdictions.

9.  EXPORT RESTRICTION.  You  will  comply  fully  with  all  applicable  laws  and  regulations  of  United
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States  and  other  countries  ("Export  Laws")  to  assure  that  Software  is  not:  (a)  exported,  directly  or
indirectly, in violation of Export Laws; or (b) used for any purpose prohibited by Export Laws.

10.  GOVERNING  LAW.  Any  use  of  the  program  which  is  illegal  under  international  or  local  law  is
forbidden by this license. Any such action is the sole responsibility of the person committing the action.

11. TERM. This Agreement becomes effective on the date  You legally  acquire the Software and will
automatically terminate if You breach any of its terms. Upon termination of this Agreement, You must
destroy the original  and all  copies of  the Software or  return them to  Dekart  and  delete  the Software
from Your system(s).

12. NO SPYWARE. The Dekart software does not contain spyware of any kind. It does not install any
tracking software on your system, or collect personal information about you and your browsing habits.
Dekart software does not "spy" on other programs you run or web sites you visit. We also don't serve
monitor usage or serve ads from the client software. The Dekart software does not come bundled with
any third party software.

13.  ROOT  CERTIFICATE  INSTALLATION.  In  order  to  offer  our  users  a  secure  connection
environment a root CA certificate is installed into the Trusted Root Certificate Authorities store. Having
this certificate installed the users can safely access our website via SSL/HTTPS connection protocols
and send or receive any sensitive information (e.g. names, addresses, etc) without the threat for these
data being seen. This allows our users to securely register their license keys at Dekart website, submit
their support  requests to Dekart  and ensure the privacy of  the information transmitted over  the web.
DEKART CERTIFICATE POLICY.  We hold  ourselves  fully  liable  to  our  customers  for  the  privacy  of
their  personal  information.  You  may  rest  assured  that  we  will  never,  under  any  circumstances,
voluntarily or willingly disclose any information to any third party. That is our guarantee to you.

14. TRADEMARK ATTRIBUTIONS. All registered and unregistered trademarks are the sole property
of their respective owners.

2 Contacting Dekart

E-mail:

Purchasing or reselling the software: sales@dekart.com

Technical support: support@dekart.com

General feedback: info@dekart.com

WWW: www.dekart.com

3 Glossary

SIM Manager - the name of the application.

PIN (Personal Identification Number) -  a secret number that gives you access to the SIM card.

PUK (Personal Unblocking Key) - a secret number that allows you to unblock a SIM card which was
blocked after entering an invalid PIN several times in a row (see unblocking a PIN).

mailto:sales@dekart.com
mailto:support@dekart.com
mailto:info@dekart.com
http://www.dekart.com
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4 Introduction

4.1 SIM Manager's feature highlights

SIM  Manager  is  an  application  that  allows  you  to  easily  manage  the  contents  of  a  SIM  card,  and
perform operations such as:

- add, remove or edit  phonebook contacts;

- create backups of  phonebook  files ;

- sort the contacts of the SIM phonebook;

- enable, disable or change the PIN; 

- etc.

Highlights

1. Ease of use - interacting with a SIM card  is much easier with a computer, than it is with a phone;

2. Mobility  -  transfer  contacts  from  one  SIM  to  another  when  changing  mobile  operators,  quickly
update the phone prefixes when traveling from one country to another;

3. Interoperability  -  the  phonebook  can  be  exported  to  a  CSV  file  and  further  processed  by  other
applications; the same mechanism can be used to synchronize the contents of multiple SIM cards,
or merge the contacts from different applications (ex: organizers, email clients, etc);

4. Wide  compatibility  -  SIM  Manager  works  with  any  SIM  card,  regardless  of  the  phone  model  you
have,  or  the  operator  you  are  subscribed  to.  There  is  no  need  to  purchase  additional  cables  to
connect the phone to the computer, since SIM Manager interacts with the SIM card directly, using a
smart card reader.

4.2 SIM Manager's components

SIM Manager's package consists of the software modules, and this guide.

4.3 System requirements

Hardware requirements
· Personal computer with an available port (ex. COM, USB) for the smart card reader.

· A PC/SC compliant smart-card reader.

Software requirements
· Windows  2000, ME, XP, 2003.

· Smart card reader driver.

4.4 Supported equipment

SIM Manager supports the following equipment:

SIM-cards
Phase 1, 2, 2+ SIM and USIM (including Nextel) cards. 
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Smart card readers: 
SIM Manager works with any PC/SC compliant smart card reader, such as: 

· Dekart SIM Card Reader;
· Datakey DKR smart card reader series; 
· GemPlus GemPC smart card reader series ;
· OmniKey CardMan smart card reader series;
· Schlumberger Reflex smart card reader series; 
· Towitoko CHIPDRIVE smart card reader series. 

A  full  list  of  supported  devices  is  available  on  our  web-site:
http://www.dekart.com/products/supported_devices/

5 Installing, updating and removing SIM Manager

· Installing SIM Manager;
· Updating SIM Manager;
· Uninstalling SIM Manager.

5.1 Installing SIM Manager

1. Close your currently open applications before installing SIM Manager.

2. Run SIMManager.exe to start the installation process. 

3. Once the welcome screen is shown, click Next to continue the installation.

http://www.dekart.com/products/hardware/sim_card_reader/ 
http://www.dekart.com/products/supported_devices/


Installing, updating and removing SIM Manager 6

© Dekart

5. Read the license agreement and accept its terms in order to continue the installation.
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6. Enter the registration details.
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7. Choose the folder in which SIM Manager will be installed.
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8. Choose SIM Manager's Start Menu entry.
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9. Additional installation options can be chosen at this step.
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10. Press Finish to complete the installation. 
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5.2 Updating SIM Manager

1. If SIM Manager's installation program is started again, it will find an existing copy of the program
and offer to update it.
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2. Click Next to continue; you will be shown the license agreement, which must be accepted in order
to proceed with the installation.

3. SIM Manager will collect the information it needs in order to update itself; click Next to continue.
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4. Press Finish to complete the update.
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Note. The system needs to be restarted after the update.

5.3 Uninstalling SIM Manager

1. Press  Start\Programs,  choose  the  folder  you  indicated  at  step  8  of  SIM  Manager's  installation
process (see Installing SIM Manager), and click Uninstall. An alternative way to do that is to go to
Control Panel\Add or remove programs, find SIM Manager in the list, and press Uninstall. The
following window will be shown on the screen.

Click Yes if you wish to continue uninstalling the software.

2. The following window will be shown on the screen when SIM Manager is uninstalled.
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6 Using SIM Manager

6.1 Starting the application

The application can be started in one of the following ways: 

· Go to Start\Programs,  choose the program's  folder  (see step  8  of  Installing  SIM Manager),
and launch the application. 

· Open the  folder  to  which  the  program  was  installed  (see  step  7  of  Installing  SIM Manager),
and launch the application meditor.exe. 

When started for the first time, the program will ask you whether you wish to associate it with PHN files
(this is SIM Manager's phonebook format). Click OK if you wish to do this, otherwise click Cancel.

Note: This can be done later, via the program's Options menu.

This is how the program's main window looks like.
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The top region of the window contains the control panel. You can perform an action either by clicking
its icon, or by choosing the respective menu item (File, Edit, SIM, Options, Help). Below you can find
the list  of  smart  card readers  known to your  system,  and the  information  stored  on the  card  (phone
book, SMS archive, etc).

6.2 Available operations

SIM Manager provides the following functionality:

Managing the phonebook
New file creates a new phonebook
Open file opens an existing phonebook
Close closes the current phonebook
Save saves the phonebook to a file
Save as... saves the phonebook to a different file
Print prints the phonebook

Add contact adds a new contact to the phonebook
Edit contact edits a contact from the phonebook
Add prefix automatically add a prefix (or change it) to a group of phone
Find and replace finds and replaces contact information
Copy copies a contact to the clipboard
Paste pastes a contact from the clipboard into the current phonebook
Cut cuts an SMS or a contact from the phonebook into the clipboard
Delete delete an SMS or a contact from the phonebook
Undo reverts a previous action (add,cut,delete)
Redo performs a reverted action again
Undelete SMS recovers an SMS that was marked as deleted

Using the SIM card
Read SIM reads data from the SIM card
Write SIM writes data to the SIM card
Change PIN1 changes PIN1
Change PIN2 changes PIN2
Backup SIM creates a backup of the SIM card
Restore SIM restores a SIM card from a previously made backup
Properties displays the properties of a SIM card
Close closes the SIM card

Options
Change font changes the font used to display the phonebook and other SIM card

data
Settings customizes the program's settings

Help
Readme displays SIM Manager's readme file
About displays the software version and the registration information

Quit closes SIM Manager
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6.3 Configuring SIM Manager

It is advised that you review SIM Manager's settings and customize them when you start the program
for the first time. To do that, use the Options menu.

Change font... allows you to choose a custom font, which will be used by SIM Manager.

Choose the desired font, and press OK to confirm your choice.

SIM Manager's additional settings can be modified by clicking Settings.



Using SIM Manager 20

© Dekart

Here is a list of items that can be changed:
1. Associate the <.phn> file extension (or  a custom one)  with SIM Manager.  If  this  is  enabled,  SIM

Manager can be started by double-clicking a phonebook file; the file will be loaded automatically.

2. Allow contacts without names.  If enabled, SIM Manager will allow you to write contacts that don't
have a name to the card and to the local file.  Note. The contacts entered without name will not be
visible when displayed on the phone. 

3. Save CSV in current ANSI codepage. If the option is enabled, SIM Manager will write the CSV files
in  a  non-Unicode  format,  using  the  default  ANSI  codepage  of  the  system.  Normally  this  feature
can be turned off, and it should only be used when the CSV files are going to be further processed
by a non-Unicode application (such as Microsoft Excel, prior to the 2007 version).

4. Save  only  GSM  contacts  to  CSV  file.  The  CSV  files  will  only  contain  the  contacts  of  the
phonebook, while other numbers (ex: own numbers, last dialled numbers, etc) will not be stored.

5. Associate the <.bsf> file extension (or a custom one) with SIM Manager phonebook backup files.

6. Select interface language allows you to choose the language of the program's interface. Note. To
apply the new settings, restart SIM Manager.

7. Save windows positions  will  memorize the size and the position of  SIM Manager's  window. Next
time  you  start  the  program,  these  settings  will  be  reused;  otherwise  -  the  windows'  size  and
location will be restored to its default settings. 

8. Show toolbar buttons text  will  show the title of  a button under  its  icon.  Please note that  in  some
languages button titles may be rather long, so not all the buttons will be shown on the toolbar. 

9. Read/Write all files from SIM card. If you enable this option, SIM Manager will read all the files (ex:
phonebook,  own  numbers,  etc)  of  the  SIM  card  at  once;  otherwise  only  the  phonebook  will  be
read/written.

10. Write to SIM updated files only.  If  enabled, SIM Manager will  only write data to the card, if  there
were changes (ex: a number was modified, a new entry was added, etc). 

11. Show deleted SMS. Some phones mark an SMS as deleted instead of actually deleting it from the
SIM  card.  If  this  option  is  checked,  SIM  Manager  will  retrieve  such  SMSes.  An  SMS  that  was
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marked as deleted will be shown in red. This option is useful if you want to recover a deleted SMS.
   

12. Allow gaps in phonebook. Gaps can be formed in the phonebook if  contacts are removed. If  this
option is checked, the gaps will be removed, thus the list of contacts will be continuous.

Press OK to apply the new settings.

6.4 Managing the phonebook

6.4.1 Creating a new phonebook

To create a new phonebook, press File -> New file..., or press the New button on the toolbar. A new
phonebook will be created:

To add a new contact, choose the desired section of the phonebook and press Add, or go to Edit ->
Add contact....

If you add a contact to a Nextel phonebook, the following window will be shown:
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For other types of SIM cards, the following dialog is used.

Fill in the fields and press OK to confirm; pressing Cancel will abort the operation. 

After you add contacts to your phonebook, the program's main window will be updated:
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To save the new file to the disk, press File -> Save As... (for more details, see Saving a phonebook to
a file). 
To write the contacts to a SIM card, press SIM -> Write SIM (for  more details,  see Writing to a SIM
card).

Note: You can create and edit multiple phonebooks at the same time.

Note: If "Allow contacts without names" is enabled in the program's settings, you can create contacts
that don't have a name assigned to them.

Note: The SMS messages section can only be read (i.e. you cannot modify its contents)

6.4.2 Editing the phonebook

To edit a phonebook, open a previously created one via File -> Open file..., or  read a SIM card. 

Editing a contact 
1. Click on the contact you wish to edit.
2. Press the Edit button on the toolbar, or go to Edit -> Edit contact. 
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3. Press OK after making your modifications.

Changing the position of a contact in the list
1. Click on the contact the position of which you wish to change.
2. Press the Up button to move the contact up, or the Down button to move it down. This can be done

with multiple contacts at the same time.

Choosing multiple contacts 
Multiple contacts can be selected by holding the Shift (or Ctrl)  button on the keyboard while clicking
the contact with the mouse.

Copying contacts to the clipboard 
1. Select the contacts from the list (you can select multiple contacts).
2. Press the Copy button, or go to Edit -> Copy.

Pasting the contacts from the clipboard 
1. Copy  the contacts to the clipboard.
2. Press the Paste button, or go to Edit -> Paste. The contacts will be pasted into the nearest unused

records on the SIM card.
3. If you need to paste the contact(s) several times, repeat the previous action. 

Cutting contacts to the clipboard
1. Select the contacts from the list (you can select multiple contacts).
2. Press the Cut button, or go to Edit -> Cut.

Moving the contacts from the clipboard to a different location 
1. Cut  the contacts to the clipboard, then move to the section of the phonebook to which you want to

move the contacts to.
2. Press the Paste button, or go to Edit -> Paste. The contacts will be pasted into the nearest unused

records on the SIM card.
3. If you need to paste the contact(s) several times, repeat the previous action. 

Note.  Contacts  can  be  transferred  between  the  sections  of  a  phonebook,  or  between  different
phonebooks.

Deleting contacts 
1. Select the contacts from the list (you can select multiple contacts).
2. Press the Delete button, or go to Edit -> Delete.

Undoing your actions 
Your actions can be undone by pressing the Undo button. This can also be done by pressing Edit ->
Undo.

Redoing your actions (cancelling undo)
You  can  redo  a  previously  undone  action,  by  pressing  the  Redo  button.  This  can  also  be  done  by
pressing Edit -> Redo.
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Adding a prefix to phone numbers
1. Choose the contacts in the phonebook.
2. Click Edit -> Add prefix.

3. Enter the prefix in the Prefix field; if you want to replace an existing prefix, enter the number of digits
to remove in the Number of symbols to remove field. Note that if the number of digits to remove is
0, then the prefix will simply be added to the existing numbers.

Note. To avoid accidental data loss, don't forget to save your phonebook to a file or to the SIM-card!

Note.  You  can  use  standard  system  hotkeys  to  perform  basic  operations:  Copy  (Ctrl+C),  Paste
(Ctrl+V), Delete (Del), Cut (Ctrl+X), Undo (Ctrl+Z), Redo (Ctrl+Y)

6.4.3 Saving the phonebook to a file

To save a phoebook to a file, press the Save button, or go to File -> Save as... or File -> Save.
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Select the folder to which you want to save the file and enter its name.
Select the type of the file - the default choice is <.phn> (or the extension you chose in the program's
settings),  and  enter  the  name  of  the  file.  SIM  Manager  also  allows  you  to  save  a  phonebook  to  a
<.csv> file (which can be further processed by other applications, such as organizers and mail clients).

Note.  If  you  wish  to  use  the  CSV  file  in  a  non-Unicode  application  (ex:  older  versions  of  Microsoft
Excel), enable the save CSV in current ANSI codepage option in the program's settings. 

6.4.4 Sorting the contacts of a phonebook

The contacts of a phonebook can be sorted (in alphabetical order, or by their numbers). This can be
done by clicking on the title of the column.

For  instance,  if  you  wish  the  contacts  to  be  sorted  by name,  click  on  the  title  of  the  Name  column.
Clicking the column title again will reverse the order (ex: from A to Z, or from Z to A).

Sorting the contacts by their phone number is done in a similar fashion.

6.4.5 Using find and replace

The  Find  and  replace  function  can  be  handy  if  you  are  dealing  with  a  phonebook  that  has  many
contacts, or if there are many contacts that have similar names.
To use this function, press the Find button, or go to Edit -> Find and replace....
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Enter  the text  you wish to search for,  and press Search.  You can refine  the  search  by enabling  the
Match case or Match whole word options.

The  found  text  can  be  automatically  replaced  with  a  different  one,  if  you  type  a  new  value  in  the
Replace  field  and  press  Replace.  By  pressing  the  button  repeatedly,  SIM  Manager  will  find  and
replace other occurrences of the text.

Note. The Find and replace feature is convenient when you travel from one country to another. You
can replace country codes in your contacts' phone numbers in a single move.

6.4.6 Viewing and editing SMSes

The SMS messages stored on the SIM card can be viewed by switching to the SMS messages section
of the phonebook. Note that the SMSes must be read from the SIM card first.
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Editing an SMS 
1. Choose the SMS you wish to edit.
2. Double-click the an editable field. Note: the Date and Position fields cannot be edited.
3. Enter the changes.
4. Press Enter to apply.

Deleting an SMS
1. Choose the SMS you wish to delete.
2. Press Delete (on the screen or on the keyboard), or go to Edit -> Delete.  Note.  If SIM Manager is

configured  to  show  deleted  SMSes,  the  deleted  SMS  will  remain  in  the  list  of  messages,  but  its
colour will be changed to red..

Recovering an SMS that was marked as deleted 
1. Choose an SMS (shown in red).
2. Right-click the message, press Undelete.

To apply the changes, press Save (if  you are working with a file), or Write (if  you are working with a
SIM card).

6.4.7 Printing the phonebook

To print out the contents of your phonebook, press Print on the toolbar, or go to File -> Print....

The following options can be set:
1. print file name;
2. print the name of the application - SIM Manager;
3. print the current date;
4. print page numbers;
5. use an alternative title - this can be helpful if  you wish to specify some additional details about the

phonebook;
6. print  logo -  SIM Manager's  logo  will  be  printed  by default,  but  you  can  choose  a  different  one  by

pressing Browse;

To save the new settings, press Apply, otherwise click Cancel.
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Press Print to print the phonebook.

6.5 Using the SIM card

6.5.1 Reading a SIM card

When a  SIM card  is  plugged  into  the  card  reader,  a  small  SIM card  icon  will  be  shown  next  to  the
reader's name in the list.

Press the Read button, or go to SIM -> Read SIM. 

Once SIM Manager finishes reading the card, the contents of the SIM will be shown on the screen.
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6.5.2 Writing to a SIM card

To write data to a SIM card, press the Write button, or go to SIM -> Write SIM. If multiple card readers
are connected to the system, you will be asked which card you wish to write to (the readers that have a
SIM card plugged in will be shown with an icon of SIM a card on their left).

Choose a SIM from the list  and press OK.  A progress bar  will  illustrate how much of  the process is
complete.
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Some sections of the SIM card are protected with the PIN2; if one such section was modified, you will
be asked to enter PIN2.

Enter PIN2 and press OK.

Note. If the code you entered is incorrect, you can try to enter it again. The bottom right corner of the
window  notifies  you  how  many  entry  attempts  there  are  left,  several  (usually  three)  unsuccessful
attempts in a row will block the SIM card (you can unblock it later with the PUK). Keep in mind the fact
that the number of attempts is limited; entering an invalid code will decrease the number of attempts
by one and change the labels' style to bold red. 

6.5.3 Changing the PIN of a SIM card

To change the PIN codes of a SIM card, go to SIM -> Change PIN1..., or SIM -> Change PIN2....

Enter  the  current  PIN  and  press  OK.  You  can  minimize  the  chance  of  entering  an  incorrect  PIN  by
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accident, if you check the Show option. If the PIN you entered is correct, SIM Manager will ask you to
enter a new PIN, and then confirm your new choice. 

Note. If the code you entered is incorrect, you can try to enter it again. The bottom right corner of the
window  notifies  you  how  many  entry  attempts  there  are  left,  several  (usually  three)  unsuccessful
attempts in a row will block the SIM card (you can unblock it later with the PUK). Keep in mind the fact
that the number of attempts is limited; entering an invalid code will decrease the number of attempts
by one and change the labels' style to bold red. 

6.5.4 Unblocking a PIN

Entering an incorrect PIN several times in a row will block the SIM card. If you attempt to read a card
with  a  blocked  PIN,  SIM  Manager  allows  you  to  unblock  the  card,  by  entering  the  PUK,  and  then
choosing a new PIN.

Entering an incorrect PUK can permanently block the SIM card! 

6.5.5 Creating a SIM backup

A backup of your SIM card allows you to easily recover your contacts and other details in case
the SIM is damaged, or if the phone is lost or stolen. 

To create a backup of your SIM card, go to SIM -> Backup SIM....
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Choose the location and the name of the backup file and press Save. A progress bar will illustrate the
status of the backup process.

6.5.6 Restoring data from a SIM backup

To restore your  data from a previously made SIM backup,  go to SIM -> Restore  SIM....  You will  be
asked to indicate the backup file which contains your data, find that file and press Open.
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A progress bar will illustrate the status of the restore process.

6.5.7 Viewing the properties of a SIM card

SIM Manager allows you to view some of the SIM card's properties, such as the states of the PIN and
PUK codes, the type of the card, the card's serial number, etc.

To view the properties of a card, go to SIM -> Properties. 
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6.5.8 Closing a SIM card's phonebook

When you are done managing a SIM card, you should close it via SIM -> Close.

6.6 Exporting the phonebook to another application

Sometimes  you  might  need  to  use  the  data  of  your  phonebook  in  a  different  application  (ex:  Word,
Excel, Palm Desktop, Eudora, Outlook, etc). SIM Manager offers several ways to do that.

1.  The contacts can be selected (note that you can select multiple contacts,  as shown in the picture
below) and copied to the clipboard, then pasted into the other application.
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When pasted into the other program, the contacts will appear as a list, with one item on each line. The
name of the contact is separated from the number by a semicolon ';' (as shown in the picture below).
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2.  You  can  also  transfer  contacts  into  SIM  Manager,  by  copying  them  to  the  clipboard  and  pasting
them to one of SIM Manager's phonebooks. Note that the contacts will only be processed if they were
written  in  a  special  format  -  one  contact  per  line,  the  name  is  separated  from  the  number  with  a
semicolon - ';' (as shown in the picture above).

3.  SIM  Manager  can  also  interact  with  other  applications  via  CSV  files.  A  CSV  can  help  you
synchronize  the  address  book  of  your  mail  client  (ex:  Outlook,  or  Eudora)  with  the  address  book  of
your organizer (ex: Palm Desktop) and with your SIM card. For details, see saving a phonebook to a
file.

6.7 Viewing SIM Manager's version

To view details about the program's version, go to Help -> About....

The window that is shown on the screen will display detailed version information about each of SIM
Manager's components.
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If you are using an unregistered version of SIM Manager, the About window will look slightly different,
see Registering SIM Manager.

6.8 Exiting SIM Manager

To quit SIM Manager, go to File -> Exit, or click the program window's close button.

7 Additional information

7.1 Registering SIM Manager

To register SIM Manager, enter your registration information in the program's About window.
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If  your unregistered copy of  SIM Manager has expired, the About  window will  look  as  the one in the
picture below.
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If  you  use  a  trial  version  of  the  program,  please,  use  the  Dekart  Buy  on-line  page  to  purchase  a
registration number. After your transaction is processed, you will receive an email with the registration
number.

7.2 Error messages and their meanings

Error message Suggested action

You can't add a new item! Try to make some free space on the SIM card
by removing unused records.

The  "..."  extension  is  not  currently  associated  with
the  SIM  Manager,  click  OK  to  associate  the  file,
otherwise click Cancel.

SIM Manager is not associated with phonebook
(phn) files, you can change this by pressing OK
. Note that this setting can be changed later.

SIM Card blocked finally! The  SIM  card  is  permanently  blocked  and  it
cannot  be  used.  The  card  needs  to  be
replaced.

https://www.dekart.com/store/
https://www.dekart.com/store/
https://www.dekart.com/store/
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