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1 License agreement

  Dekart.
  http://www.dekart.com

                    END-USER SOFTWARE LICENSE AGREEMENT

IMPORTANT: THIS END-USER SOFTWARE LICENSE AGREEMENT ("AGREEMENT") IS A LEGAL
AGREEMENT  BETWEEN YOU  (EITHER  AN  INDIVIDUAL  OR  A  SINGLE  ENTITY)  AND  DEKART.
("DEKART")  FOR  THE  SOFTWARE  IDENTIFIED  ABOVE.  BY  INSTALLING,  COPYING,  OR
OTHERWISE  USING  ALL  OR  ANY  PORTION  OF  THE  SOFTWARE  YOU  ACCEPT  ALL  THE
TERMS AND CONDITIONS OF THIS  AGREEMENT.  IF  ANY OF THE  TERMS  AND  CONDITIONS
ARE  NOT  ACCEPTABLE  TO  YOU,  DO  NOT  USE  THE  SOFTWARE;  INSTEAD,  RETURN  THE
PACKAGE  TO  THE  COMPANY  FROM  WHICH  YOU  RECEIVED  IT  AND  YOU  WILL  RECEIVE  A
FULL REFUND IF YOU: (A) DO NOT USE THE SOFTWARE AND (B) RETURN IT WITH PROOF OF
PAYMENT WITHIN THIRTY (30) DAYS OF THE PURCHASE DATE.

1.  DEFINITIONS.  "Software"  means (a)  all  of  the  contents  of  the  files,  disk(s),  CD-ROM(s)  or  other
media  with  which  this  Agreement  is  provided,  including  but  not  limited  to  (i)  Dekart  or  third  party
computer information or software; (ii) related explanatory written materials or files ("Documentation");
and (iii) fonts; and (b) upgrades, modified versions, updates, additions, and copies of the Software, if
any,  licensed  to  you  by  Dekart  (collectively,  "Updates").  "Use"  or  "Using"  means  to  access,  install,
download, copy or otherwise benefit from using the functionality of the Software in accordance with the
Documentation. "Dekart" means Dekart  SRL, having its legal address at Alba Iulia 75, Chisinau, MD
2071, Moldova, and / or its affiliates/branches.

2. GRANT OF LICENSE. As long as you comply with  the terms of  this  Agreement,  Dekart  grants  to
You  a  non-exclusive,  non-transferable  right  for  Your  internal  use  to  Use  the  Software  in  a  quantity
necessary for its intended purposes described in the Documentation. The Software may include or be
bundled with other software programs licenses under different terms and/or licensed by a vendor other
than  Dekart.  Use  of  any  software  programs  accompanied  by  a  separate  license  agreement  is
governed by that separate license agreement. Any third party software that may be provided with the
Software is included for use at Your option. Dekart is not responsible for any third party's software and
shall have no liability for Your use of third party software.

2.1.  With  the  STANDARD  SINGLE-USER  License  Dekart  grants  you  with  the  right  to  use  the
accompanying  Dekart  Software  and  any  of  its  updates  that  you  may  receive  on  a  single  terminal
connected to a single computer  (i.e.,  with  a single CPU).  You may,  however,  install  the Software on
more  than  one  computer  provided  you  do  not  operate  the  Software  on  more  than  one  computer  or
computer  terminal  at  a  time.  In  case  the  user  needs  to  deploy  the  purchased  software  on  several
computers simultaneously another license has to be purchased, namely Multi-User License or the user
may alternatively select to have a separate license key per each terminal.

2.2. MULTI-USER, NETWORK LICENSE. You may use the Software on a network only if a separate
copy  of  the  Software  has  been  licensed  from  Dekart  for  each  terminal  and/or  CPU  capable  of
executing  the  Software.  Otherwise,  if  you  desire  to  use  the  Software  on  a  network  or  multi-user
system, or to install the Software on multiple single-user CPUs, you must first obtain written multi-user
authorization  (a  "Multi-user  License")  from  Dekart.  Under  a  Multi-user  License,  you  may  install  the
Software on networks and/or multiple single-user CPUs, provided the total concurrent network usage
or  total  number  of  network  installations  (whichever  is  greater),  plus  the  total  number  of  single-user
installations,  does  not  exceed  the  total  number  of  machines/users  authorized  by  Dekart.  The  Multi-
User  License  Key  consists  of  a  standard  combination  of  25  symbols  plus  5  more  symbols  which
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indicate the overall number of users authorized by Dekart with this particular license.

3.  EVALUATION.  If  the  Software  is  an  evaluation  version  or  is  provided  to  You  for  evaluation
purposes,  then  Your  license  to  use  the  Software  is  limited  solely  to  internal  evaluation  purposes  in
accordance  with  the  terms  of  the  evaluation  offering  under  which  You  received  the  Software  and
expires 30 days from installation (or such other period as indicated by the Software) and the Software
may  cease  to  function.  Upon  expiration  of  the  evaluation  period,  You  must  discontinue  use  of  the
Software and delete the Software entirely from Your system. The Software may contain an automatic
disabling mechanism that prevents its use after a certain period of time, so You should back up Your
system and take other measures to prevent any loss of files or data.

4. REFUNDS. Products that can be downloaded prior to the purchase are NOT refundable. Optionally,
our technical support team can decide that an exception to the rule can be made, after an examination
of  the  problem.  You  have  the  chance  to  'try  before  you  buy'.  We  would  like  to  emphasize  that  the
evaluation period is an important phase and we encourage you to explore the programs and try all their
options before the purchase.  If  you have not  tested  the fully-functional,  free  evaluation  versions  that
can be retrieved from our download site(s), PLEASE do so before you place your order to make sure
that the product you are ordering is the product you need.

5.  INTELLECTUAL  PROPERTY RIGHTS.  The  Software  and  any  copies  that  You  are  authorized  by
Dekart to make are the intellectual property of and are owned by Dekart. No title to or ownership of the
Software  is  transferred  to  You.  Dekart  owns  and  retains  all  title  and  ownership  of  all  intellectual
property rights in the Software, including any adaptations or copies. You acquire only a license to use
the Software. The structure, organization and code of the Software are the valuable trade secrets and
confidential information of Dekart. The Software is copyright protected.

6.  NON-DEKART  PRODUCTS.  The  Software  may  include  or  be  bundled  with  hardware  or  other
software programs licensed or sold by a vendor other then Dekart. Any such products are provided on
and "AS IS" basis and are not warranted by Dekart.  Any warranty service for non-Dekart  products is
provided by the product vendor in accordance with the applicable vendor warranty.

7. LIMITED WARRANTY. Dekart warrants to You that for ninety (90) days from date of purchase (the
"Warranty  Period):  (a)  the  media  on  which  the  Software  is  stored  will  be  free  of  defects;  (b)  the
Software will substantially conform to the Documentation accompanying the Software. If the defective
item(s) are returned to Dekart or if  You send an error report(s) to Dekart within the Warranty Period,
Dekart will  at its sole discretion either resolve the problem(s),  or  replace the Software,  or  refund the
license fees You paid for the Software. Any misuse or unauthorized modification of the Software voids
this warranty. The warranty referenced above is  Your sole and exclusive remedy and is  in  lieu of  all
other  warranties,  express  or  implied.  The  warranty  referenced  above  does  not  apply  to  Software
provided free  of  charge.  Such Software  is  provided "AS IS"  without  any  warranties  of  any  kind.  The
Software  is  not  designed,  manufactured  or  intended  for  use  of  distribution  with  on-line  control
equipment  in  hazardous  environments  requiring  fail-safe  performance.  Such  as  in  the  operation  of
nuclear facilities, aircraft navigation, communication, or control systems, direct life support machines,
weapons systems, or other uses in which failure of the software could lead directly to death, personal
injury, or serve physical or environment damage.

8.  LIMITATION  OF  LIABILITY.  IN  NO  EVENT  WILL  DEKART  BE  LIABLE  TO  YOU  FOR  ANY
DAMAGES,  CLAIMS  OR  COSTS  WHATSOEVER  OR  ANY  CONSEQUENTIAL,  INDIRECT,
INCIDENTAL  DAMAGES,  OR  ANY  LOST  PROFITS  OR  LOST  SAVINGS,  EVEN  IF  AN  DEKART
REPRESENTATIVE  HAS  BEEN  ADVISED  OF  THE  POSSIBILITY  OF  SUCH  LOSS,  DAMAGES,
CLAIMS  OR  COSTS  OR  FOR  ANY  CLAIM  BY  ANY  THIRD  PARTY.  THE  LIMITATIONS  AND
EXCLUSIONS  REFERENCED  ABOVE  APPLY  TO  THE  EXTENT  PERMITTED  BY  APPLICABLE
LAW IN YOUR JURISDICTION. DEKART'S AGGREGATE LIABILITY UNDER OR IN CONNECTION
WITH THIS AGREEMENT SHALL BE LIMITED TO THE AMOUNT PAID FOR THE SOFTWARE, IF
ANY. The above exclusions and limitations will not apply to claims relating to death or personal injury.
In those jurisdictions that do not allow the exclusion or limitations damages, Dekart's liability shall  be
limited or excluded to the maximum extent allowed within those jurisdictions.
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9.  EXPORT RESTRICTION.  You  will  comply  fully  with  all  applicable  laws  and  regulations  of  United
States  and  other  countries  ("Export  Laws")  to  assure  that  Software  is  not:  (a)  exported,  directly  or
indirectly, in violation of Export Laws; or (b) used for any purpose prohibited by Export Laws.

10.  GOVERNING  LAW.  Any  use  of  the  program  which  is  illegal  under  international  or  local  law  is
forbidden by this license. Any such action is the sole responsibility of the person committing the action.

11. TERM. This Agreement becomes effective on the date  You legally  acquire the Software and will
automatically terminate if You breach any of its terms. Upon termination of this Agreement, You must
destroy the original  and all  copies of  the Software or  return them to  Dekart  and  delete  the Software
from Your system(s).

12. NO SPYWARE. The Dekart software does not contain spyware of any kind. It does not install any
tracking software on your system, or collect personal information about you and your browsing habits.
Dekart software does not "spy" on other programs you run or web sites you visit. We also don't serve
monitor usage or serve ads from the client software. The Dekart software does not come bundled with
any third party software.

13.  ROOT  CERTIFICATE  INSTALLATION.  In  order  to  offer  our  users  a  secure  connection
environment a root CA certificate is installed into the Trusted Root Certificate Authorities store. Having
this certificate installed the users can safely access our website via SSL/HTTPS connection protocols
and send or receive any sensitive information (e.g. names, addresses, etc) without the threat for these
data being seen. This allows our users to securely register their license keys at Dekart website, submit
their support  requests to Dekart  and ensure the privacy of  the information transmitted over  the web.
DEKART CERTIFICATE POLICY.  We hold  ourselves  fully  liable  to  our  customers  for  the  privacy  of
their  personal  information.  You  may  rest  assured  that  we  will  never,  under  any  circumstances,
voluntarily or willingly disclose any information to any third party. That is our guarantee to you.

14. TRADEMARK ATTRIBUTIONS. All registered and unregistered trademarks are the sole property
of their respective owners.

2 Contacting Dekart

E-mail:

Purchasing or reselling the software: sales@dekart.com

Technical support: support@dekart.com

General feedback: info@dekart.com

WWW: www.dekart.com

3 Glossary

SIM Explorer -  the name of the application.

GSM - Global System for Mobile communications.

PLMN - Public Land Mobile Network.

HPLMN - Home PLMN.

PIN/PIN2  -  Personal  Identification  Number  /  Personal  Identification  Number  2  (obsolete  terms  for
CHV1 and CHV2, respectively).

mailto:sales@dekart.com
mailto:support@dekart.com
mailto:info@dekart.com
http://www.dekart.com
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PUK/PUK2  -  PIN Unblocking  Key /  PIN2  Unblocking  Key (obsolete  terms  for  UNBLOCK CHV1 and
UNBLOCK CHV2, respectively).

CHV - Card Holder Verification information; access condition used by the SIM for the verification of the
identity of the user.

ATR - Answer To Reset.

RFU - Reserved for Future Use.

ICC - Integrated Circuit(s) Card.

MSISDN - Mobile Station international ISDN number.

SoLSA - Support of Localised Service Area.

AC - Access Condition.

ACL - APN Control List.

ACM -  Accumulated Call Meter

ADF - Application Dedicated File.

ADM - Access condition to an EF which is under the control of the authority which creates this file.

ADN - Abbreviated Dialling Number.

AHAG - Ad-Hoc Authentication Group.

AID - Application Identifier.

AK - Anonymity key.

A-Key - Authentication Key.

ALW – ALWays.

AMPS - Analogue Mobile Phone System.

ANSI - American National Standards Institute.

AoC - Advice of Charge.

APDU - Application Protocol Data Unit.

BCCH - Broadcast Control Channel.

BCD - Binary Coded Decimal.

BDN - Barred Dialling Number.

BTS - Base Transmitter Station.

CB - Cell Broadcast.
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CBMI - Cell Broadcast Message Identifier.

CCP - Capability/Configuration Parameter.

CLA – CLAss.

CLI - Calling Line Identifier.

CNL - Co-operative Network List.

CPBCCH - COMPACT Packet BCCH.

CTS - Cordless Telephony System.

DCK - De-personalization Control Keys.

DCS - Digital Cellular System.

DF - Dedicated File (abbreviation formerly used for Data Field).

DTMF -  Dual Tone Multiple Frequency.

ECC - Emergency Call Code.

EF - Elementary File.

EIA - Electronics Industries Alliance (North America).

eMLPP - enhanced Multi-Level Precedence and Pre-emption Service.

ETSI - European Telecommunications Standards Institute.

etu - elementary time unit.

FDN - Fixed Dialling Number.

GMSI - Group Identity.

IC - Integrated Circuit.

ICI - Incoming Call Information.

ICT - Incoming Call Timer.

ID – Identifier.

IEC - International Electrotechnical Commission.

IK - Integrity key.

IMSI - International Mobile Subscriber Identity.

ISO - International Organization for Standardization.

Kc - Cryptographic key; used by the cipher A5.
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Ki - Subscriber authentication key; the cryptographic key used by the authentication algorithm.

KSI - Key Set Identifier.

LAI - Location Area Information; information indicating a cell or a set of cells.

lgth - The (specific) length of a data unit.

LI - Language Indication.

LND - Last Number Dialled.

LSA ID - Localised Service Area Identity.

LSA - Localised Service Area.

LSB - Least Significant Bit.

MAC - Message authentication code.

MCC - Mobile Country Code.

ME - Mobile Equipment.

MExE - Mobile Execution Environment.

MF - Master File.

MMI - Man Machine Interface.

MNC - Mobile Network Code.

MS - Mobile Station.

MSB - Most Significant Bit.

NAM - Numeric Assignment Module.

NET – NETwork.

NEV – NEVer.

NPI - Numbering Plan Identifier.

OCI - Outgoing Call Information.

OCT - Outgoing Call Timer.

OFM - Operational Feature Monitor.

OPLMN - Operator Controlled PLMN (Selector List).

OTA - Over The Air.

PDC - Personal Digital Communications.
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PPS  - Protocol and Parameter Select (response to the ATR).

RAND - A RANDom challenge issued by the network.

SDN - Service Dialling Number.

SID - System Identity.

SIM - Subscriber Identity Module.

SMS - Short Message Service.

SRES - Signed RESponse calculated by a SIM.

SSC - Supplementary Service Control string.

SW1/SW2 - Status Word 1 / Status Word 2.

TETRA - TErrestrial Trunk RAdio the identity of the user.

TIA - Telecommunications Industries Association (North America).

TMSI - Temporary Mobile Subscriber Identity.

TON - Type Of Number.

TP - Transfer layer Protocol.

TPDU - Transfer Protocol Data Unit.

TS - Technical Specification.

UNBLOCK CHV1/2 - value to unblock CHV1/CHV2 UNBLOCK CHV2, respectively.

USAT - USIM Application Toolkit.

USIM - Universal Subscriber Identity Module.

VBS - Voice Broadcast Service.

VGCS - Voice Group Call Service.

VLR - Visitor Location Register.

VPLMN - Visited PLMN.

XRES - Expected user RESponse
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4 Introduction

4.1 SIM Explorer's purpose and feature highlights

Dekart SIM Explorer is an intelligent tool which allows you to process the contents of a 2G (GSM) or
3G (USIM) card.

SIM Explorer's quick feature list
1. View and edit the contents of a SIM card.  
2. Powerful search mechanism.
3. Several  scanning modes:  smart  scan is  fast  and able  to  find  any standard  GSM or  USIM file;  full

scan will find all the files on the card, even if they are not defined by the standards.
4. View information about standard GSM and USIM files, as well as interpret their contents.
5. View detailed information about the SIM card and the smart card reader.
6. View the status and manage the SIM card's access codes (the state of PIN and PUK, the number of

code entering attempts remaining, change the PIN, enable or disable the PIN, unblock the card).
7. Backup and restore individual files, as well as the entire SIM card.
8. Activate or deactivate files (if you have sufficient privileges).
9. Increase cyclic files.
10.Manage ADF files.
11.Interpret and display SIM/USIM toolkit applications.
12.Interpret and display a SIM card's ATR
13.Comes with an extendable list of PLMN codes.
14.Comes with an extendable list of language codes.

SIM Explorer's highlights
1. Ease of  use  -  a)  the  card  is  managed  using  the  possibilities  of  a  PC (full-sized  keyboard,  large

screen, etc), b) the information is displayed in a human-friendly form, c) the software can operate
with the card's contents directly.

2. Full  control   -  a  smart  scanning  mechanism  allows  you  to  find  GSM and  USIM files,  as  well  as
non-standard files on the SIM card, while the ability to manually search for files that meet certain
criteria gives you even more flexibility.

3. Universal compatibility - the software works with SIM cards (of any vendor, issued by any mobile
operator) via a smart card reader.

4.2 SIM Explorer's components

SIM Explorer's package consists of the software modules, and this guide.

4.3 System requirements

Hardware requirements
· Personal computer with an available port (ex. COM, USB) for the smart card reader.

· A PC/SC compliant smart-card reader.

Software requirements
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· Windows  2000, XP, 2003, Vista

· Smart card reader driver.

4.4 Supported equipment

SIM Explorer supports the following equipment:

SIM-cards
Phase 1, 2, 2+ SIM and USIM cards. 

Smart card readers: 
SIM Manager works with any PC/SC compliant smart card reader, such as: 
· Dekart SIM Card Reader.
· Datakey DKR smart card reader series. 
· GemPlus GemPC smart card reader series. 
· OmniKey CardMan smart card reader series. 
· Schlumberger Reflex smart card reader series. 
· Towitoko CHIPDRIVE smart card reader series. 

A  full  list  of  supported  devices  is  available  on  our  web-site:
http://www.dekart.com/products/supported_devices/

5 Installing, updating and removing SIM Explorer

· Installing SIM Explorer;
· Updating SIM Explorer;
· Uninstalling SIM Explorer.

5.1 Installing SIM Explorer

Make sure that the smart card reader's driver is installed before installing SIM Explorer.

1. Close your currently open applications before installing SIM Explorer. 

2. Run SIMExplorer.exe to start the installation process. 

3. Once the welcome screen is shown, click Next to continue the installation.

http://www.dekart.com/products/hardware/sim_card_reader/ 
http://www.dekart.com/products/supported_devices/
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5. Read the license agreement and accept its terms in order to continue the installation.
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6. Enter the registration details.
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7. Choose the folder in which SIM Explorer will be installed..
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8. Choose SIM Explorer's Start Menu entry.
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9. Additional installation options can be chosen at this step.
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10. Press Finish to complete the installation. 
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5.2 Updating SIM Explorer

1. If  SIM Explorer's installation program is started again, it  will  find an existing copy of  the program
and offer to update it.
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2. Click Next to continue; you will be shown the license agreement, which must be accepted in order
to proceed with the installation.

3. SIM Explorer will collect the information it needs in order to update itself; click Next to continue.
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4. Press Finish to complete the update.



SIM Explorer Help19

© Dekart

Note. The system needs to be restarted after the update.

5.3 Uninstalling SIM Explorer

1. Press  Start\Programs,  choose  the  folder  you  indicated  at  step  8  of  SIM  Manager's  installation
process (see Installing SIM Explorer), and click Uninstall. An alternative way to do that is to go to
Control Panel\Add or remove programs, find SIM Explorer in the list, and press Uninstall. The
following window will be shown on the screen.

Click Yes if you wish to continue uninstalling the software.

1. The following window will be shown on the screen when SIM Explorer is uninstalled.
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6 Using SIM Explorer

6.1 Starting the application

The application can be started in one of the following ways: 

· Go to  Start\Programs,  choose  the  program's  folder  (see  step  8  of  Installing  SIM Explorer),
and launch the application.

· Open the folder to which the program was installed (see step 7 of Installing SIM Explorer), and
 launch the application.

The program's main window will  be shown on the screen. If  no smart card readers were found, or  if
there are multiple card readers available, SIM Explorer's window will look as follows:
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The top part contains the application's toolbar. You can perform an action by pressing the buttons on
the toolbar, or by finding the appropriate item in the menu (File, Record, View, SIM, Readers, Tools,
Help). 

The left side of the window contains a list of available smart card readers. If a SIM card was scanned,
its directory structure will be shown under the list of readers.

The right side of the window displays information about the currently selected file or directory, as well
as an interpreted version of its contents.

Toopen a SIM card:

1. Plug the card into the card reader.

2. If there are multiple smart card readers in the system, choose one from the list.

 

6.2 Available operations

SIM Explorer provides the following functionality: 

Files on the SIM card
Open Template read the directory structure of a SIM using a template file
Save Template save the directory structure of the SIM to a template file
Find File find file
View File Binary view the file in a Hex-editor
Edit File Binary edit the file in a Hex-editor
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Backup File backup a file
Restore File restore file from a backup
Invalidate (Deactivate) File deactivate file
Rehabilitate (Activate) File activate file
Increase File (Cyclic) increase cyclic file

Managing records  
View Record Binary view the record in a Hex-editor
Edit Record Binary edit the record in a Hex-editor

Managing a SIM card
Security Access Codes manage access codes (enter PIN or PUK, enable or disable PIN

protection, change PIN, unblock SIM)
Backup SIM backup the data of a SIM card
Restore SIM restore SIM from a backup
ATR Details interpret the card's ATR
Scan scan SIM card

Smart-card reader related
operations 
Refresh Readers List refresh the list of smart-card readers
Reader Attributes view information about a smart-card reader and the SIM card

plugged into it

Code references
PLMN Coding manage the PLMN codes list
Languages Coding manage the languages codes list

Application settings
View (File Summary, File Contents)enable or disable the display of SIM card's files or their contents
Customize customize SIM Explorer's appearance (interface language, and

whether security codes masking is enabled or disabled)

Viewing information about the
program
About view information about the program's version, as well as the

registration information

Exit quit the application

 

6.3 Configuring SIM Explorer

1. You can customize the appearance of SIM Explorer's main window by pressing View in the menu,
and checking the desired options:

· File Summary - display brief information about the currently selected file;

· File Contents - display the contents of the currently selected file;
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· You can check only one of the options, or both;

2. The application's interface language can be changed via Tools -> Customize.

3. Show security  codes (PIN/PUK) allows you to control  how security codes will  be displayed on the
screen: masked by asterisks (more secure), or shown in a human-readable form (less likely to enter
an incorrect code).

4. Press ОК to apply the new settings.

5. Go to Tools -> Save Settings to save the new settings.

6.4 Operating with the files of a SIM card

6.4.1 Reading the directory structure of a card using a template

When SIM Explorer is started, it will automatically read the currently plugged-in card, using the default
template.  To  choose  a  different  template,  press  Open  Template  or  go  to  File  ->  Open  Template.
Choose the template file, then press Open.
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Note. A template can be created in one of the following ways:
· Perform a full scan of the card;
· Find specific files on the card.

Then save the resulting directory structure to a new template file.

6.4.2 Creating a new template

When performing a full scan of the card, or finding specific files on the card, the file structure shown
by SIM Explorer is  modified;  this  structure can be saved to a template file  for  future use.  To save a
template, press Save Template or go to File -> Save Template. 
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6.4.3 Finding files on the SIM

To find a specific file, or a group of files on the SIM, press Find File or go to File -> Find File.

Enter a file mask in the Search for field, and the name of  the directory in which the file(s)  should be
searched in the Search in field. Press Start Search  to continue. The first file that matches the given
criteria will be shown; if you wish to find all the files, check Find all files.
Additional search criteria can be defined by pressing Show Advanced >>.
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Depending on the chosen File type, the following criteria can be set: File struct, File size, Record len,
Record count. Press Start Search to continue.

6.4.4 Viewing a file in binary

In certain cases you may wish to view a record in a Hex-editor:

1. Open the SIM card.

2. Choose the desired file from the directory structure.

3. Go to File -> View File Binary (or press F3, or double-click the file).
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6.4.5 Editing a file in binary

SIM Explorer allows you to edit files in a Hex-editor.

Note 1. Some files can only be edited if you have the required access privileges.

Note 2. To increase cyclic files, use the Increase File (Cyclic) feature.

1. Open the SIM card.

2. Choose the desired file from the directory structure.

3. Go to File -> Edit File Binary (or press F4) to open the file editor.

4. To edit a byte, double-click it, then enter the new value.

5. Press Enter to confirm.

6. Press OK to close the editor.
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6.4.6 Backing up a file

To backup a file on the SIM card, follow these steps:

1. Open the SIM card.

2. Choose the file (enter the access code if requested).

3. Go to File -> Backup File.

4. Choose the name and the path to the backup file.

5. Press Save.

6.4.7 Restoring a file from a backup

To restore a file from a previously made backup, follow these steps:

1. Open the SIM card.

2. Go to File -> Restore File.

3. Choose the backup file.

4. Press Open.

Note. Make sure the size of the SIM card is large enough to fit the contents of the backup file.
To check the available free space, view the properties of the 3F00 directory.
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6.4.8 Deactivating/Activating a file

To activate or deactivate a file, follow these steps:
1. Open the SIM card.
1. Choose the desired file from the directory structure.

2. Go  to  File  ->  Invalidate  (Deactivate)  File  to  deactivate  a  file;  to  activate  it,  go  to  File  ->
Rehabilitate (Activate) File.

Note.  Some  files  cannot  be  activated  or  deactivated  unless  you  have  the  required  access
privileges.

6.4.9 Increasing a cyclic file

To increase a cyclic file, follow these steps:

1. Open the SIM card.
2. Choose the desired file from the directory structure.

3. Go to File -> Increase File (Cyclic).

4. Double-click the word you wish to edit.

5. Press Enter.

6. Press OK to close the Hex-editor.
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You will notice that the records of the cyclic files were shifted after the update.

Note. Some files cannot be modified unless you have the required access privileges.

6.5 Manipulating file records on the SIM card

6.5.1 Viewing a record

To view a selected in the Hex-editor, follow these steps:

1. Open the SIM card.

2. Choose the desired file from the directory structure, then select the record you wish to view.

3. Go to Record -> View Record Binary (or press F3, or double-click the record).
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6.5.2 Editing a record

Records can be edited in SIM Explorer's built-in Hex-editor.

Note. Some files can only be edited if you have the required access privileges.

1. Open the SIM card.

2. Choose the desired file from the directory structure, and then indicate the record you wish to edit.

3. Go to Record -> Edit Record Binary (or press F4) to open the Hex-editor.

4. To edit a byte, double-click it.
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3. Press Enter to apply the changed value.
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4. Press ОК to close the Hex-editor.

6.6 Operating with the SIM card

6.6.1 Backing up a SIM card

In case the mobile phone gets lost, or if the SIM card is damaged, you can lose all your data. To
avoid such cases, we strongly recommend you to use SIM Explorer's SIM backup feature.

To backup a SIM card, follow these steps:

1. Scan the SIM card.

2. Provide the PIN codes.

3. Go to SIM -> Backup SIM.
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Choose  the  name  and  the  path  to  the  backup  file,  then  press  Save.  The  progress  of  the  backup
process will be shown on the screen. Once the backup is complete, a copy of a card is obtained, the
contents of which matches the contents of the directory structure on the left.

6.6.2 Restoring a SIM card from a backup

To restore a SIM card from a previously made backup, follow these steps:

1. Insert the SIM card into the reader. 

Note. Make sure the size of the SIM card is large enough to fit the contents of the backup file.

2. Choose the smart card reader from the list.

3. Go to SIM -> Restore SIM.

Choose the SIM backup file and press Open.
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The progress of the restore process will be shown on the screen.

6.6.3 Scanning a SIM card

The SIM card must be scanned in order to obtain detailed information about the contents of the SIM
card and its directory structure.

1. After you open a card, go to SIM -> Scan. You will be asked to choose a scan mode.

2. Choose the Smart mode if you are looking for files that are typical to SIM cards.
3. Choose the Full mode if you wish to find all the files that are located on the SIM card.

The  scan  process  may  take  a  while,  especially  if  performed  in  the  Full  mode.  The  progress  of  the
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procedure will be shown on the screen. Once the scan is complete, the file-structure on the left will be
updated, while SIM Explorer's log will contain information about the number of found files and the time
it took to complete the scan.

6.6.4 Interpreting the ATR of a SIM

The ATR of a SIM card is shown in the bottom right corner of SIM Explorer's window. The ATR can be
interpreted by choosing SIM -> ATR Details. 
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By pressing ATR in Hex Editor you can view and modify (if the card allows this) the ATR.
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6.6.5 Operating with security codes

Some of the areas of a SIM card are protected, accessing them is only possible by providing a valid
PIN code. The PIN codes can be supplied via SIM -> Security Access Codes. 

Note.  To  avoid  cases  in  which  you  accidentally  type  in  a  wrong  PIN,  enable  Show  security
codes (PIN/PUK).

1. To verify the SIM card's PIN, check Enable PIN, then enter the PIN and press OK.

2. To verify the card's PIN2, enter it, and press OK. 
3. To view more details about the card's access codes, press Show Details >>. You will see the state

of the PIN and that of the PUK, and the number of entry attempts left.
Note: if a USIM card is accessed in 3G mode, the information about the number of remaining
entry attempts will not be available.
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4. To enable PIN-code protection, press Enable PIN and enter the PIN.
5. To change the PIN, press Enable PIN, enter the current PIN, then press Change PIN.  You will be

asked to enter the new PIN, and then confirm it.
6. To change PIN2,  enter  the current  PIN2,  then press  Change PIN2.  If  you  pressed Change PIN2

without entering the current code, the Enter old PIN2 prompt will be shown on the screen.
7. Press  Cache  security  codes  if  you  want  SIM Explorer  to  remember  them  (thus  the  codes  do  not

have to be entered nex time the card is used). 
Note:  the  access  codes  are  stored  in  plain  text  in  SIM  Explorer's  folder  (see  step  7)  in  the  file
security[ICCID].ini.  
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5. Check Show next time at startup if you want the Security Access Codes window to be shown next
time a SIM card is open.

If an invalid PIN is entered multiple times, the number of remaining entry attempts will become zero. In
this case the card cannot be used unless it is unblocked.

6.6.6 Unblocking a PIN

If an invalid PIN was entered multiple times, the number of PIN entering attempts will become 0. In this
case  the  SIM  card  cannot  be  accessed  unless  the  PIN  is  unblocked.  To  unblock  a  PIN  using  SIM
Explorer:

1. Go to SIM -> Security Access Codes.

2. Press Show Details >>.

3. Enter PUK1 and press Unblock SIM to unblock the SIM card.

4. Enter PUK2 and press Unblock PIN2 to unblock PIN2.
5. Once the card is successfully unblocked, SIM Explorer will prompt you for a new PIN.

If an incorrect PUK is entered multiple times, the SIM card is permanently blocked! 

6.7 Managing smart-card readers

6.7.1 Updating the list of smart-card readers

When  a  new  card  reader  is  plugged  into  the  system,  the  list  of  available  readers  will  be  updated
automatically.

If you wish to manually update the list, go to Readers -> Refresh Readers List.

6.7.2 Viewing the properties of a smart-card reader and of the current SIM card

To view the properties of the smart-card reader that is in use, as well as the properties of the SIM card
that is currently in use:

1. Open a SIM card.

2. Go to Readers -> Reader Attributes.
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6.8 SIM Explorer's additional features

6.8.1 Managing the library of PLMN codes

SIM  Exporer  comes  with  a  built-in  library  of  PLMN  codes.  The  list  can  be  viewed  and  updated  via
Tools -> PLMN Coding.
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The PLMN Coding window illustrates the current PLMN codes of the list. To add a new code, fill in the
fields (MCC, MNC, Operator, Network, Country) and press Add PLMN.
To delete an existing code, select it and press Delete Selected.

6.8.2 Managing the library of language codes

SIM Exporer comes with a built-in library of language codes. The list can be viewed and updated via
Tools -> Languages Coding.
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The  Languages  Coding  window  illustrates  the  current  language  codes  of  the  list.  To  add  a  new
language code, fill in the fields (Language code, and Language Name) and press Add Language.
To delete an existing code, select it and press Delete Selected.

6.9 Viewing SIM Explorer's version information

To view details about the program's version, go to Help -> About....

The window that is shown on the screen will display detailed version information about each of SIM
Explorer's components.
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If you are using an unregistered version of SIM Explorer, the About window will look slightly different,
see Registering SIM Explorer.

6.10 Exiting SIM Explorer

To quit SIM Explorer, go to File -> Exit, or click the program window's close button.

7 Additional information

7.1 Registering SIM Explorer

To register SIM Explorer, enter your registration information in the program's About window.
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If your unregistered copy of SIM Explorer has expired, the program registration window will be shown
next time you start the application. 



Additional information 46

© Dekart

If  you  use  a  trial  version  of  the  program,  please,  use  the  Dekart  Buy  on-line  page  to  purchase  a
registration number. After your transaction is processed, you will receive an email with the registration
number.

7.2 Error messages

Error message Suggested actions

Providing all the access codes is not
mandatory, but this will ensure that you can
read every accessible file on the card;
otherwise some files will not be accessible.

Try  to  free  up  some  space  on  the  SIM  card  by
deleting unused records, then attempt to perform the
operation again

New PIN and confirmation is different.
New PIN2 and confirmation is different

Enter  the PIN one more time,  making sure that  the
original PIN and the confirmation PIN are identical

SIM card is blocked, click Details to enter
PUK1

The SIM card is blocked, to unblock it, go to SIM ->
Security Access Codes -> Details and enter PUK1

PIN2 is blocked, click Details to enter PUK2 PIN2 is blocked, to unblock it, go to SIM -> Security
Access Codes -> Details and enter PUK2

PUK1 is blocked
PUK2 is blocked

The SIM card is blocked

Verify PIN1 Error
Verify PIN2 Error

Perform  the  operation  again,  making  sure  that  you
enter the right PIN

https://www.dekart.com/store/
https://www.dekart.com/store/
https://www.dekart.com/store/
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Note. If you encounter error messages that are not listed above, contact Dekart's technical
support: http://www.dekart.com/support/howto/howto-contact-us/ .

7.3 Files SIM Explorer can handle

Below is a list of GSM and USIM files SIM Explorer can interpret.

File Description

0x2FE2  ICC Identification)

0x2F05  Extended language preference)

0x4F30  SAI (SoLSA Access Indicator) (if parent is 0x5F70)

0x4F30  Phone Book Reference file (if parent is 0x5F3A)

0x4F31  SoLSA LSA List

0x6F05  Language preference

0x6F07  International Mobile Subscriber Identity (IMSI).

0x6F20  Ciphering key Kc

0x6F30  PLMN selector

0x6F31  HPLMN search period

0x6F37  ACM maximum value

0x6F38  SIM service table (if parent is 0x7F20 or 0x7F21)

0x6F38  USIM Service Table (if parent is 0xADF0 or 0xFFF0)

0x6F39  Accumulated call meter

0x6F3E  Group Identifier Level 1

0x6F3F  Group Identifier Level 2

0x6F46  Service Provider Name

0x6F41  Price per unit and currency table

0x6F45  Cell broadcast message identifier selection

0x6F74  Broadcast control channels

0x6F78  Access control class

0x6F7B  Forbidden PLMNs

0x6F7E  Location information

0x6FAD  Administrative data

0x6FAE  Phase identification

0x6FB1  Voice Group Call Service

0x6FB2  Voice Group Call Service Status

0x6FB3  Voice Broadcast Service

0x6FB4  Voice Broadcast Service Status
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0x6FB5  Enhanced Multi Level Pre-emption and Priority

0x6FB6  Automatic Answer for eMLPP Service

0x6F48  Cell Broadcast Message Identifier for Data Download

0x6FB7  Emergency Call Codes

0x6F50  Cell broadcast message identifier range selection

0x6F2C  De-personalization Control Keys

0x6F32  Co-operative Network List

0x6F51  Network's Indication of Alerting

0x6F52  GPRS Ciphering key KcGPRS

0x6F53  GPRS location information

0x6F54  SetUpMenu Elements

0x6F60  PLMN Selector with Access Technology

0x6F61  Operator controlled PLMN Selector with Access Technology

0x6F62  HPLMN Access Technology

0x6F63  CPBCCH Information

0x6F64  Investigation PLMN Scan

0x6F3A  Abbreviated dialling numbers

0x6F3B  Fixed dialling numbers

0x6F3C  Short messages

0x6F3D  Capability configuration parameters

0x6F40  MSISDN

0x6F42  Short message service parameters

0x6F43  SMS status

0x6F44  Last number dialled

0x6F49  Service Dialling Numbers

0x6F4A  Extension1

0x6F4B  Extension2

0x6F4C  Extension3

0x6F4D  Barred Dialling Numbers

0x6F55  Extension4

0x6F4E  Extension4 (if parent is 0x7F10)

0x6F4E  Extension5 (if parent is 0xADF0 or 0xFFF0)

0x6F47  Short message status reports

0x6F65  RPLMN Last used Access Technology

0x4F40  MExE-ST

0x4F41  ORPK

0x4F42  ARPK
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0x4F43  TPRPK

0x4F20  IMG (if parent is 0x5F50)

0x4F20  GSM Ciphering key Kc (if parent is 0x5F3B)

0x2F00  Application directory

0x2F06  Access rule reference

0x4F22  Phone book Synchronisation Counter

0x4F23  Change Counter

0x4F24  Previous Unique Identifier

0x4F52  GPRS Ciphering key KcGPRS

0x4F63  CPBCCH Information

0x4F64  Investigation PLMN Scan

0x6F06  Access Rule Reference

0x6F08  Ciphering and Integrity Keys

0x6F09  Ciphering and Integrity Keys for Packet Switched domain

0x6F56  Enabled Services Table

0x6F57  Access Point Name Control List

0x6F58  Comparison Method Information

0x6F5B  Initialisation values for Hyperframe number

0x6F5C  Maximum value of START

0x6F73  Packet Switched location information

0x6F80  Incoming Call Information

0x6F81  Outgoing Call Information

0x6F82  Incoming Call Timer

0x6F83  Outgoing Call Information

0x6FC3  Key for hidden phone book entries

0x6FC4  Network Parameters

Below is a list of USIM files SIM Explorer can interpret (ADFusim\5F3Aphonebook).

ADN  Abbreviated dialling numbers

IAP  Index Administration Phone book

EXT1  Extension1

SNE  Second Name Entry

ANR  Additional Number

PBC  Phone Book Control

GRP  Grouping file

AAS  Additional number Alpha String
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GAS  Grouping information Alpha String

UID  Unique Identifier

EMAIL  e-mail address

CCP1  Capability Configuration Parameters 1

SIM/USIM  toolkit applications

ADF  Application Dedicated Files
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